Calmac website search form
FAQs
Back to Tickets and Reservations

Which browsers are compatible with your online booking process?


To get the best possible service when you are using our online booking process, please ensure that you are using the most up to date browsers.

In general, we recommend that you use the following browsers or at least minus 2 versions for your device. For example, for Firefox you must have at least version 47+ or as recommended below version 67+.

Web Browsers we recommend on our website.

Web Browser

Device

Version/Operating System

Chrome

PC/Laptop

58 +

 

Android Mobile/Tablet

5 +

Firefox

PC/Laptop

67 +

Safari

MacBook/Laptop

OSX 10.9 Operating System

 

iPhone/iPad

iOS 5 Operating System

 

How useful was this content?
1.6 / 5
average from 31 votes
Tell us your rating
Tell us your rating
Close Don't show again